一个输出桃心的程序
2023-09-10 08:15:02
发布于:吉林
桃心输出
后续还会优化改进
第四次改进
输入样例
1
10
输出样例
* * * * * *
* * * * * * * * * *
* * * * * * * * * * * * * *
* * * * * * * * * * * * * * * * * *
* * * * * * * * * * * * * * * * * * *
* * * * * * * * * * * * * * * * * * *
* * * * * * * * * * * * * * * * * * *
* * * * * * * * * * * * * * * * *
* * * * * * * * * * * * * * *
* * * * * * * * * * * * *
* * * * * * * * * * *
* * * * * * * * *
* * * * * * *
* * * * *
* * *
*
注释:输入数字为桃心底部大三角的高
#include<bits/stdc++.h>
using namespace std;
int j=1;
int main(){
cout<<"选择模式:\n";
cout<<"1.手动模式\n2.自动模式\n";
int o;
cin>>o;
while(j<=58){
int a;
if(o==1)cin>>a;
else {
a=j;
j++;
}
int h=a,b=a*2-1;
int l=(b-1)/2,x=1;
int r=l;
while(r>=a/2+1-a/10*2){
r-=2;
x++;
}
for(int i=x;i>=1;i--){
for(int j=1;j<=i-1;j++){
cout<<" ";
}
for(int j=1;j<=r;j++){
cout<<" *";
}
for(int j=1;j<=i*2-1;j++){
cout<<" ";
}
for(int j=1;j<=r;j++){
cout<<" *";
}
r+=2;
cout<<endl;
}
for(int i=1;i<=a/10*2;i++){
for(int j=1;j<=b;j++){
cout<<" *";
}
cout<<endl;
}
for(int i=1;i<=h;i++){
for(int j=1;j<=i-1;j++){
cout<<" ";
}
for(int j=1;j<=b-i*2+2;j++){
cout<<" *";
}
cout<<endl;
}
}
return 0;
}
这里空空如也
有帮助,赞一个